Supported Browsers - Internet Explorer 8 & Firefox 3.6

All Categories > Web Site Issues
If you are experiencing issues viewing your website or erratic behavior when editing in your admin when using Internet Explorer or Firefox, the first step is to make sure that you are using the most current version.

  • To check your version in Firefox go to the help menu and the top of the browser and click on about Mozilla Firefox.
  • To check your version of Internet explorer, go to the help menu at the top of the browser and click on about Internet Explorer.

3/16/11 - Currently the browsers that we support are Firefox 3.6 & version 4and Internet Explorer 8 & 9.

Note: Safari and Chrome are typically not browsers that we support. For more information click on Submit a Ticket. A BANG! representative will contact you with more information.

Add Feedback